- Posts: 783
- Thank you received: 0
Help help help cisco routing
- skepticals
- Offline
- Elite Member
Less
More
17 years 1 month ago #23569
by skepticals
Replied by skepticals on topic Re: Help help help cisco routing
[code:1]write erase[/code:1]
Then
[code:1]reload[/code:1]
Then
[code:1]reload[/code:1]
17 years 1 month ago #23572
by vitamin
Replied by vitamin on topic Re: Help help help cisco routing
cool
I have done the reload.
So I have been taking to a Router> promt.
I have done the reload.
So I have been taking to a Router> promt.
- skepticals
- Offline
- Elite Member
Less
More
- Posts: 783
- Thank you received: 0
17 years 1 month ago #23575
by skepticals
Replied by skepticals on topic Re: Help help help cisco routing
Okay. Start with the basics:
[code:1]
conf t
hostname cisco2600
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
int e0/0
ip address 192.168.1.254 255.255.255.0
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0 [/code:1]
[code:1]
conf t
hostname cisco2600
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
int e0/0
ip address 192.168.1.254 255.255.255.0
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0 [/code:1]
17 years 1 month ago #23578
by vitamin
Replied by vitamin on topic Re: Help help help cisco routing
o.k now do i need to save that at all>?
[code:1]Building configuration...
Current configuration : 641 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco2600
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.254 255.255.255.0
full-duplex
!
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0
shutdown
full-duplex
!
ip classless
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
[/code:1]
So that is my config at the present moment in time.
[code:1]Building configuration...
Current configuration : 641 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco2600
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.254 255.255.255.0
full-duplex
!
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0
shutdown
full-duplex
!
ip classless
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
[/code:1]
So that is my config at the present moment in time.
- skepticals
- Offline
- Elite Member
Less
More
- Posts: 783
- Thank you received: 0
17 years 1 month ago #23579
by skepticals
Replied by skepticals on topic Re: Help help help cisco routing
Yes, save it:
[code:1]write memory[/code:1]
What is your topology? You have 1 router and two PCs? Are they connetect to a switch or are you directly plugged into the router's interfaces?
[code:1]write memory[/code:1]
What is your topology? You have 1 router and two PCs? Are they connetect to a switch or are you directly plugged into the router's interfaces?
- skepticals
- Offline
- Elite Member
Less
More
- Posts: 783
- Thank you received: 0
17 years 1 month ago #23588
by skepticals
Replied by skepticals on topic Re: Help help help cisco routing
I setup a quick test in my lab:
PC1: 192.168.1.100 255.255.255.0
Default Gateway 192.168.1.254
PC2: 192.168.2.100
Default Gateway 192.168.2.254
Here is how I connected them:
PC1==Crossover Cable==E0/0
PC2==Crossover Cable==E0/1
One machine is running XP and the other is running Windows 2000
[code:1]
Current configuration : 793 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco
!
logging queue-limit 100
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.254 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0
half-duplex
!
ip http server
no ip http secure-server
ip classless
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
[/code:1]
I was able to ping all interfaces and accross to the other PC from either direction.
I even removed the routes and it worked because the networks are directly connected:
PC1: 192.168.1.100 255.255.255.0
Default Gateway 192.168.1.254
PC2: 192.168.2.100
Default Gateway 192.168.2.254
Here is how I connected them:
PC1==Crossover Cable==E0/0
PC2==Crossover Cable==E0/1
One machine is running XP and the other is running Windows 2000
[code:1]
Current configuration : 793 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco
!
logging queue-limit 100
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.254 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 192.168.2.254 255.255.255.0
half-duplex
!
ip http server
no ip http secure-server
ip classless
ip route 192.168.1.0 255.255.255.0 Ethernet0/0
ip route 192.168.2.0 255.255.255.0 Ethernet0/1
!
!
!
!
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
[/code:1]
I was able to ping all interfaces and accross to the other PC from either direction.
I even removed the routes and it worked because the networks are directly connected:
no ip route 192.168.1.0 255.255.255.0 Ethernet0/0
no ip route 192.168.2.0 255.255.255.0 Ethernet0/1
Time to create page: 0.137 seconds