- Posts: 16
- Thank you received: 0
Cisco 2600 as Internet Gateway
- ghostphace
- Topic Author
- Offline
- New Member
Less
More
16 years 1 week ago #28055
by ghostphace
Replied by ghostphace on topic Re: Cisco 2600 as Internet Gateway
Below is the config i have on the Cisco 2600 router. There is internet when i ping from the router but from the LAN there is none.
!
ip subnet-zero
ip cef
!
async-bootp dns-server x.x.x.x x.x.x.x
!
!
!
!
!
interface Ethernet0/0
description to WAN
ip address x.x.x.x 255.255.255.240
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Ethernet0/1
description to LAN
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/2
no ip address
no ip directed-broadcast
shutdown
!
ip default-gateway x.x.x.x "IP on WAN Interface"
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x "IP on WAN Interface"
ip route 192.168.1.0 255.255.255.0 Ethernet0/1
no ip http server
!
!
line con 0
login local
transport input none
line aux 0
line vty 0 4
login local
!
no scheduler allocate
end
!
ip subnet-zero
ip cef
!
async-bootp dns-server x.x.x.x x.x.x.x
!
!
!
!
!
interface Ethernet0/0
description to WAN
ip address x.x.x.x 255.255.255.240
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Ethernet0/1
description to LAN
ip address 192.168.1.2 255.255.255.0
no ip directed-broadcast
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/2
no ip address
no ip directed-broadcast
shutdown
!
ip default-gateway x.x.x.x "IP on WAN Interface"
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x "IP on WAN Interface"
ip route 192.168.1.0 255.255.255.0 Ethernet0/1
no ip http server
!
!
line con 0
login local
transport input none
line aux 0
line vty 0 4
login local
!
no scheduler allocate
end
16 years 1 week ago #28056
by S0lo
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Replied by S0lo on topic Re: Cisco 2600 as Internet Gateway
You've configured the interfaces correctly as it seams. As SteveP mentioned, I think you can indeed use your 2600 instead of the netgear. You already confirmed that you can ping internet IPs from your router. I'd try changing the following:
1. Remove the ip default-gateway x.x.x.x command. It should be used only when routing is disabled. www.cisco.com/en/US/tech/tk365/technolog...186a0080094374.shtml
2. Remove the ip route 192.168.1.0 255.255.255.0 Ethernet0/1 command. There is absolutely no need for it. The router will automatically install the route in the routing table since it already has the interface info. (Try show ip route to be sure of that).
3. Here is where I think the problem is. If you are using DHCP on your LAN (automatically obtain IPs). Then you might need to configure your 2600 as a DHCP server. Try this:
[code:1]Router# configure terminal
Router(config)# ip dhcp pool LAN1
Router(config)# network 192.168.1.0 255.255.255.0
Router(config)# default-router 192.168.1.2
Router(config)# dns-server <dns_ip_from_ISP>[/code:1]
Note here that I'm assuming your netgear was doing DHCP for your LAN. So your 2600 router has to do the same thing.
4. If you are using static IPs on your lan (not DHCP). Make sure the gateway on the LAN PCs is 192.168.1.2. And subnet mask is 255.255.255.0. And DNS server is set.
Hope this helps. By the way, may I ask why do you like to use the 2600 instead of the netgear?
1. Remove the ip default-gateway x.x.x.x command. It should be used only when routing is disabled. www.cisco.com/en/US/tech/tk365/technolog...186a0080094374.shtml
2. Remove the ip route 192.168.1.0 255.255.255.0 Ethernet0/1 command. There is absolutely no need for it. The router will automatically install the route in the routing table since it already has the interface info. (Try show ip route to be sure of that).
3. Here is where I think the problem is. If you are using DHCP on your LAN (automatically obtain IPs). Then you might need to configure your 2600 as a DHCP server. Try this:
[code:1]Router# configure terminal
Router(config)# ip dhcp pool LAN1
Router(config)# network 192.168.1.0 255.255.255.0
Router(config)# default-router 192.168.1.2
Router(config)# dns-server <dns_ip_from_ISP>[/code:1]
Note here that I'm assuming your netgear was doing DHCP for your LAN. So your 2600 router has to do the same thing.
4. If you are using static IPs on your lan (not DHCP). Make sure the gateway on the LAN PCs is 192.168.1.2. And subnet mask is 255.255.255.0. And DNS server is set.
Hope this helps. By the way, may I ask why do you like to use the 2600 instead of the netgear?
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
- ghostphace
- Topic Author
- Offline
- New Member
Less
More
- Posts: 16
- Thank you received: 0
16 years 1 week ago #28066
by ghostphace
Replied by ghostphace on topic Re: Cisco 2600 as Internet Gateway
It worked for about 20 mins and as soon as i was confortable and wanted to jump for glory i lost internet connection from the LAN.
Also i dont know if there is a conflict in the LAN because there is still an active DHCP server on the LAN apart from the Cisco 2600?
Also i dont know if there is a conflict in the LAN because there is still an active DHCP server on the LAN apart from the Cisco 2600?
16 years 1 week ago #28071
by S0lo
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Replied by S0lo on topic Re: Cisco 2600 as Internet Gateway
If your active DHCP server is correctly configured to distribute the correct IP range,subnetmask and gateway as shown above. Then you don't need the 2600 to do DHCP. You should remove lines mentioned in step 3 above. Or, you could disable your active DHCP server. You only need one DHCP server.
If that still doesn't help then try assigning one PC a static IP and try to connect to the net. If it doesn't connect, then the problem is not DHCP.
If that still doesn't help then try assigning one PC a static IP and try to connect to the net. If it doesn't connect, then the problem is not DHCP.
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
- ghostphace
- Topic Author
- Offline
- New Member
Less
More
- Posts: 16
- Thank you received: 0
16 years 2 days ago #28135
by ghostphace
Replied by ghostphace on topic Re: Cisco 2600 as Internet Gateway
I have disables DHCP on the 2600 and i still cant get it to work. can you think of something else that might be the problem.
- ghostphace
- Topic Author
- Offline
- New Member
Less
More
- Posts: 16
- Thank you received: 0
16 years 2 days ago #28137
by ghostphace
Replied by ghostphace on topic Re: Cisco 2600 as Internet Gateway
I have disabled DHCP on the 2600 but still i cant get the Internet to work from inside the LAN.
If this is not a DHCP problem what else do you think can be causing the problem?
If this is not a DHCP problem what else do you think can be causing the problem?
Time to create page: 0.134 seconds