- Posts: 26
- Thank you received: 0
Setup an ASA 5505
- matoposb0y
- Topic Author
- Offline
- Junior Member
Less
More
14 years 4 months ago #34865
by matoposb0y
Replied by matoposb0y on topic Re: Setup an ASA 5505
Should my vlan2 be configured as PPPoE?
14 years 4 months ago #34874
by S0lo
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Replied by S0lo on topic Re: Setup an ASA 5505
Assuming the IP 192.168.1.254 is your router's internal IP (facing the ASA). Vlan 2 IP should be changed in the following line:
[code:1]ip address 192.168.1.254 255.255.255.0 [/code:1]
Change the IP to something like say 192.168.1.253, like this:
[code:1]ip address 192.168.1.253 255.255.255.0 [/code:1]
The route command is correct.
Second, your router is probably doing NAT. So there is no need to redo NAT using the ASA. But it should still work with it, using your current config. Tell us what happens with only the above change.
[code:1]ip address 192.168.1.254 255.255.255.0 [/code:1]
Change the IP to something like say 192.168.1.253, like this:
[code:1]ip address 192.168.1.253 255.255.255.0 [/code:1]
The route command is correct.
Second, your router is probably doing NAT. So there is no need to redo NAT using the ASA. But it should still work with it, using your current config. Tell us what happens with only the above change.
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
- matoposb0y
- Topic Author
- Offline
- Junior Member
Less
More
- Posts: 26
- Thank you received: 0
14 years 4 months ago #34980
by matoposb0y
Replied by matoposb0y on topic Re: Setup an ASA 5505
Hi there, I bought a new router - NETGEARDG834G v5 - the router IP is 192.168.0.1 and here is my config:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.1.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.36 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
!
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
any ideas?
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 192.168.0.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.1.0 255.255.255.0
route outside 0.0.0.0 0.0.0.0 192.168.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.5-192.168.1.36 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
match default-inspection-traffic
!
!
!
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
any ideas?
- matoposb0y
- Topic Author
- Offline
- Junior Member
Less
More
- Posts: 26
- Thank you received: 0
14 years 4 months ago #34981
by matoposb0y
Why .253? could I put any other number in the range 1 - 255? is it just an ip address that is assigned by the firewall to the router?
Replied by matoposb0y on topic Re: Setup an ASA 5505
Assuming the IP 192.168.1.254 is your router's internal IP (facing the ASA). Vlan 2 IP should be changed in the following line:
[code:1]ip address 192.168.1.254 255.255.255.0 [/code:1]
Change the IP to something like say 192.168.1.253, like this:
[code:1]ip address 192.168.1.253 255.255.255.0 [/code:1]
The route command is correct.
Second, your router is probably doing NAT. So there is no need to redo NAT using the ASA. But it should still work with it, using your current config. Tell us what happens with only the above change.
Why .253? could I put any other number in the range 1 - 255? is it just an ip address that is assigned by the firewall to the router?
- matoposb0y
- Topic Author
- Offline
- Junior Member
Less
More
- Posts: 26
- Thank you received: 0
14 years 4 months ago #34983
by matoposb0y
Replied by matoposb0y on topic Re: Setup an ASA 5505
I FIXED IT! WHOOOHOOO!
Now I need to know how to access the printer which is behind the firewall from a computer who connects wirelessly to the router then the firewall and then the printer - any ideas?
Now I need to know how to access the printer which is behind the firewall from a computer who connects wirelessly to the router then the firewall and then the printer - any ideas?
14 years 4 months ago #35004
by S0lo
Yes, you can choose any number between 1 - 254.
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Replied by S0lo on topic Re: Setup an ASA 5505
Why .253? could I put any other number in the range 1 - 255? is it just an ip address that is assigned by the firewall to the router?
Yes, you can choose any number between 1 - 254.
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Time to create page: 0.151 seconds