- Posts: 438
- Thank you received: 9
Nat configuration issue
13 years 5 months ago #37170
by Nevins
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
Nat configuration issue was created by Nevins
I did this wrong buy I'm not sure how to correct it.
[code:1]!
ip nat inside source list LAN_RANGE interface Serial0/0/0 overload
ip classless
!
!
ip access-list standard LAN_RANGE
permit 192.168.0.0 0.0.0.255
![/code:1]
Here is the full configuration of router 0:
Router#show run
Building configuration...
Current configuration : 953 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 192.168.0.240 192.168.0.254
!
ip dhcp pool Lan1
network 192.168.0.0 255.255.255.0
default-router 192.168.0.254
dns-server 4.4.4.2
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip nat inside
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 15.0.0.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 15.0.0.0
!
ip nat inside source list LAN_RANGE interface Serial0/0/0 overload
ip classless
!
!
ip access-list standard LAN_RANGE
permit 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Here is the full picture of the topology (not needed but meh)
Packet Tracer files shared at:
www.2shared.com/file/duOMl7LY/Nat-configuration.html
www.2shared.com/file/sOYPWT2B/Nat-configuration.html
[code:1]!
ip nat inside source list LAN_RANGE interface Serial0/0/0 overload
ip classless
!
!
ip access-list standard LAN_RANGE
permit 192.168.0.0 0.0.0.255
![/code:1]
Here is the full configuration of router 0:
Router#show run
Building configuration...
Current configuration : 953 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 192.168.0.240 192.168.0.254
!
ip dhcp pool Lan1
network 192.168.0.0 255.255.255.0
default-router 192.168.0.254
dns-server 4.4.4.2
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip nat inside
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 15.0.0.1 255.255.255.252
ip nat outside
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 15.0.0.0
!
ip nat inside source list LAN_RANGE interface Serial0/0/0 overload
ip classless
!
!
ip access-list standard LAN_RANGE
permit 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end
Here is the full picture of the topology (not needed but meh)
Packet Tracer files shared at:
www.2shared.com/file/duOMl7LY/Nat-configuration.html
www.2shared.com/file/sOYPWT2B/Nat-configuration.html
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
13 years 5 months ago #37171
by Nevins
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
Replied by Nevins on topic Re: Nat configuration issue
I should point out that aside from private addresses being able to get past wan links all other devices are perfectly functional.
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
13 years 5 months ago #37173
by Nevins
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
Replied by Nevins on topic Re: Nat configuration issue
[code:1]Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#no ip nat inside
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip nat inside
Router(config-if)#[/code:1]
[code:1]Packet Tracer PC Command Line 1.0
PC>ping 4.4.4.2
Pinging 4.4.4.2 with 32 bytes of data:
Request timed out.
Reply from 4.4.4.2: bytes=32 time=130ms TTL=125
Reply from 4.4.4.2: bytes=32 time=150ms TTL=125
Reply from 4.4.4.2: bytes=32 time=130ms TTL=125
Ping statistics for 4.4.4.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 130ms, Maximum = 150ms, Average = 136ms
PC>[/code:1]
Glad these boards are slow... I would have robbed myself of a chance to figure it out. I was looking in the wrong place.
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/1
Router(config-if)#no ip nat inside
Router(config-if)#exit
Router(config)#int fa0/0
Router(config-if)#ip nat inside
Router(config-if)#[/code:1]
[code:1]Packet Tracer PC Command Line 1.0
PC>ping 4.4.4.2
Pinging 4.4.4.2 with 32 bytes of data:
Request timed out.
Reply from 4.4.4.2: bytes=32 time=130ms TTL=125
Reply from 4.4.4.2: bytes=32 time=150ms TTL=125
Reply from 4.4.4.2: bytes=32 time=130ms TTL=125
Ping statistics for 4.4.4.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 130ms, Maximum = 150ms, Average = 136ms
PC>[/code:1]
Glad these boards are slow... I would have robbed myself of a chance to figure it out. I was looking in the wrong place.
Useful Threads
================================
www.firewall.cx/forum/2-basic-concepts/3...e-resource-page.html
Time to create page: 0.119 seconds