- Posts: 2
- Thank you received: 0
Pasting IOS config files to hyperterminal
14 years 2 months ago #35328
by qaswed
Pasting IOS config files to hyperterminal was created by qaswed
Hi all,
Does anyone know how does pasting IOS config files as text to hyperterminal work? Does IOS executes command by command as they arrive? If it is true, consider the following commands:
interface f0/0
ip add 10.0.0.1 255.255.255.0
...
interface f1/0
ip add ...
...
That means that IOS executes second interface command in interface configuration mode of previous interface command, which cannot be accepted. What is actually true?
Thanx
Cheers
Does anyone know how does pasting IOS config files as text to hyperterminal work? Does IOS executes command by command as they arrive? If it is true, consider the following commands:
interface f0/0
ip add 10.0.0.1 255.255.255.0
...
interface f1/0
ip add ...
...
That means that IOS executes second interface command in interface configuration mode of previous interface command, which cannot be accepted. What is actually true?
Thanx
Cheers
14 years 2 months ago #35331
by JamieP
Jamie Parks
Network Engineer, UK
Replied by JamieP on topic Re: Pasting IOS config files to hyperterminal
it will work just fine
if you are in "interface confiuration mode" and type a command that does not belong to that mode, it will run the command in normal config mode. So the same could be said for
[code:1]interface fa0/1
switchport mode access
switchport access vlan 15
no ip domain-lookup[/code:1]
even though the "no ip domain-lookup" command isnt part of the interface config, it will still accept it and run the no ip domain-lookup in global config mode
hope that makes sense
if you are in "interface confiuration mode" and type a command that does not belong to that mode, it will run the command in normal config mode. So the same could be said for
[code:1]interface fa0/1
switchport mode access
switchport access vlan 15
no ip domain-lookup[/code:1]
even though the "no ip domain-lookup" command isnt part of the interface config, it will still accept it and run the no ip domain-lookup in global config mode
hope that makes sense
Jamie Parks
Network Engineer, UK
14 years 2 months ago #35332
by qaswed
Replied by qaswed on topic Pasting IOS commands
Yes,
IOS is made to work like that, it now makes sense
Thank you
IOS is made to work like that, it now makes sense
Thank you
14 years 2 months ago #35340
by SujitNair
Replied by SujitNair on topic Re: Pasting IOS config files to hyperterminal
yes you dont have to worry about it. IOS parses commands line by line, but nowadays it comes out the interface or rotuer config mode if the command is not meant for that mode.
Time to create page: 0.146 seconds