- Posts: 158
- Thank you received: 1
intervlan config problems using an external router
15 years 8 months ago #30092
by skylimit
"...you are never too old to learn" anon
intervlan config problems using an external router was created by skylimit
Hi all,
I wonder if I could get some help please. Basically, im having problems getting nodes in different VLANs to talk to each other using an external router. The design follows the hierarchical model. My problem seems to be that Im not sure how to configure the distribution switch. I'm testing this on PacketTracer5.0. My configuration follows:
Diagram: yfrog.com/bfpackettracertestj
Packettracer file: www.2shared.com/file/5384292/7c1eb0b3/intervlan_test1.html
On Core1:
[code:1] hostname CoreSw1
!
!
ip ssh version 1
no ip domain-lookup
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
!
![b]The IOS on packettracer accept the 'switchport trunk encap !dot1q command on fa0/24 -- could this be why comms aint possible?'[/b]
!
!
interface FastEthernet0/24
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
[/code:1]
On Core 2:
[code:1]
!
hostname CoreSw2
!
!
ip ssh version 1
no ip domain-lookup
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport access vlan 3
switchport mode access
!
!
![b]The IOS on packettracer wont accept the 'switchport trunk encap !dot1q' command on fa0/24 -- could this be why comms aint !possible?'[/b]
!
interface FastEthernet0/24
switchport mode trunk
!
[/code:1]
On Dist-Access Switch: (this switch is used as both distribution & access)
[code:1]
hostname Dist_Access_Sw
!
!
ip ssh version 1
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
!
![b]The IOS on packettracer wont accept the 'switchport trunk encap !dot1q' command on fa0/24 -- could this be why comms aint !possible?'[/b]
!
interface FastEthernet0/24
switchport mode trunk
!
[/code:1]
On the External Router:
[code:1]
hostname Router_On_A_Stick
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
description default gw for node1 in vlan2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
description default gw for node2 in vlan 3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.4
description default gw for node3 in vlan 4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
!
!
[/code:1]
Notes:
I think I got the cabling right, please correct me if otherwise.
Core1 Switch(fa0/24) to Dist-Access Switch (fa0/1) = Cross-over
Core2 Switch(fa0/24) to Dist-Access Switch(fa0/2) = Cross-over
Dist-Access Switch (fa0/24) to Router = Straight-through
Switches to client nodes = straight-through.
I can ping the the sub-interfaces on the router from the node in vlan 4 and thats it. I cant ping any other nodes. Also, all the nodes have their default gateway set to the corresponding sub-interface on the router..
Q2: If I were to put all nodes in the same vlan, say 2, what will I have to do for them to talk to each other apart from taking out the router.
Any help will be greatly appreciated
Thanks
I wonder if I could get some help please. Basically, im having problems getting nodes in different VLANs to talk to each other using an external router. The design follows the hierarchical model. My problem seems to be that Im not sure how to configure the distribution switch. I'm testing this on PacketTracer5.0. My configuration follows:
Diagram: yfrog.com/bfpackettracertestj
Packettracer file: www.2shared.com/file/5384292/7c1eb0b3/intervlan_test1.html
On Core1:
[code:1] hostname CoreSw1
!
!
ip ssh version 1
no ip domain-lookup
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
!
![b]The IOS on packettracer accept the 'switchport trunk encap !dot1q command on fa0/24 -- could this be why comms aint possible?'[/b]
!
!
interface FastEthernet0/24
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
[/code:1]
On Core 2:
[code:1]
!
hostname CoreSw2
!
!
ip ssh version 1
no ip domain-lookup
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport access vlan 3
switchport mode access
!
!
![b]The IOS on packettracer wont accept the 'switchport trunk encap !dot1q' command on fa0/24 -- could this be why comms aint !possible?'[/b]
!
interface FastEthernet0/24
switchport mode trunk
!
[/code:1]
On Dist-Access Switch: (this switch is used as both distribution & access)
[code:1]
hostname Dist_Access_Sw
!
!
ip ssh version 1
!
port-channel load-balance src-mac
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport mode trunk
!
!
![b]The IOS on packettracer wont accept the 'switchport trunk encap !dot1q' command on fa0/24 -- could this be why comms aint !possible?'[/b]
!
interface FastEthernet0/24
switchport mode trunk
!
[/code:1]
On the External Router:
[code:1]
hostname Router_On_A_Stick
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
description default gw for node1 in vlan2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
description default gw for node2 in vlan 3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.4
description default gw for node3 in vlan 4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0
!
!
[/code:1]
Notes:
I think I got the cabling right, please correct me if otherwise.
Core1 Switch(fa0/24) to Dist-Access Switch (fa0/1) = Cross-over
Core2 Switch(fa0/24) to Dist-Access Switch(fa0/2) = Cross-over
Dist-Access Switch (fa0/24) to Router = Straight-through
Switches to client nodes = straight-through.
I can ping the the sub-interfaces on the router from the node in vlan 4 and thats it. I cant ping any other nodes. Also, all the nodes have their default gateway set to the corresponding sub-interface on the router..
Q2: If I were to put all nodes in the same vlan, say 2, what will I have to do for them to talk to each other apart from taking out the router.
Any help will be greatly appreciated
Thanks
"...you are never too old to learn" anon
15 years 8 months ago #30136
by S0lo
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Replied by S0lo on topic Re: intervlan config problems using an external router
Played with it, here is the fixed file:
www.2shared.com/file/5423612/79ac82c7/in...lan_test1_fixed.html
Here is what I've done:
1. Define a VTP domain and configure all switches to be part of it. Like this:
[code:1]Switch(config)# vtp domain TEST1[/code:1]
TEST1 is the name of the domain I made. You have to do this on all switches. This will allow them to communicate VLAN information via VTP.
2. Define only one switch to act as a VTP server and all other switches as VTP clients. Like this:
[code:1]Dist_Switch(config)# vtp mode server
Device mode already VTP SERVER.[/code:1]
[code:1]CoreSwitch1(config)#vtp mode client
Device mode already VTP CLIENT.[/code:1]
[code:1]CoreSwitch2(config)# vtp mode client
Device mode already VTP CLIENT.[/code:1]
3. Create the rest of the VLANs in the distribution switch. I noticed that only VLAN3 is available. So I created VLAN2 and VLAN4 as follows:
[code:1]Dist_Switch(config)# vlan 2
Dist_Switch(config)# vlan 4
[/code:1]
You have to only assign them correct IPs and subnet masks. Nothing more. They will be able to talk to each other once this is done. (Ofcourse the IPs have to be part of the same subnet).
Hope this helps
www.2shared.com/file/5423612/79ac82c7/in...lan_test1_fixed.html
Here is what I've done:
1. Define a VTP domain and configure all switches to be part of it. Like this:
[code:1]Switch(config)# vtp domain TEST1[/code:1]
TEST1 is the name of the domain I made. You have to do this on all switches. This will allow them to communicate VLAN information via VTP.
2. Define only one switch to act as a VTP server and all other switches as VTP clients. Like this:
[code:1]Dist_Switch(config)# vtp mode server
Device mode already VTP SERVER.[/code:1]
[code:1]CoreSwitch1(config)#vtp mode client
Device mode already VTP CLIENT.[/code:1]
[code:1]CoreSwitch2(config)# vtp mode client
Device mode already VTP CLIENT.[/code:1]
3. Create the rest of the VLANs in the distribution switch. I noticed that only VLAN3 is available. So I created VLAN2 and VLAN4 as follows:
[code:1]Dist_Switch(config)# vlan 2
Dist_Switch(config)# vlan 4
[/code:1]
Q2: If I were to put all nodes in the same vlan, say 2, what will I have to do for them to talk to each other apart from taking out the router.
You have to only assign them correct IPs and subnet masks. Nothing more. They will be able to talk to each other once this is done. (Ofcourse the IPs have to be part of the same subnet).
Hope this helps
Studying CCNP...
Ammar Muqaddas
Forum Moderator
www.firewall.cx
Time to create page: 0.114 seconds