Skip to main content

Access-list and inter-vlan routing

More
16 years 10 months ago #23785 by the_blast
Hi all... im struggeling with a setup at home which makes me crazy..
i have 1 router 2651 and 2 2950 switches.

the setup is like a router on a stick.
i use 3 vlans 10 ( native) 20 and 200.
vlan 10 is only used for management and no clients are connected.

on switch 1 i have connected 2 pc's 1 in vlan20 and 1 in vlan200.
on switch 2 i have the same........

Pc in vlan20 on switch1 can communicate with pc in vlan20 on switch2.
Pc's in vlan200 can also communicate.

pc in vlan20 on switch1 can cummunicate with pc in vlan200 on switch1 .. but cannot communicate with pc in vlan200 on switch2
However the pc in vlan20 on switch2 can communicate with pc in vlan200 on switch1.

Can you follow !?

so the main question is why is it impossible to communicate with the pc in vlan200 on switch2 from pc in vlan20 on switch1 ???

snip of codes router
[code:1]
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.10
encapsulation dot1Q 10 native
ip address 10.0.10.10 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.0.20.10 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface FastEthernet0/0.200
encapsulation dot1Q 200
ip address 10.0.200.10 255.255.255.0
ip nat inside
no ip virtual-reassembly
!
interface Serial0/0
no ip address
shutdown
[/code:1]

Switch1
[code:1]

interface FastEthernet0/1
description ** Trunk to router fa0/0 **
switchport trunk native vlan 10
switchport mode trunk
no ip address
duplex full
speed 100
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
no ip address
spanning-tree portfast
!

!
interface FastEthernet0/10
switchport access vlan 200
no ip address
spanning-tree portfast
!
interface FastEthernet0/11
description ** Trunk RSC_BAR_2950 fa0/11 **
switchport trunk native vlan 10
switchport mode trunk
switchport nonegotiate
no ip address
duplex full
speed 100
!

interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 10.0.10.20 255.255.255.0
no ip route-cache
!

!
ip default-gateway 10.0.10.10[/code:1]

Switch 2
[code:1]
!
interface FastEthernet0/2
description Bar
switchport access vlan 20
switchport mode access
speed 100
duplex full
spanning-tree portfast

!
interface FastEthernet0/10
description WLAN RSC
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
description ** Trunk RSC_HOME_
switchport trunk native vlan 10
switchport mode trunk
switchport nonegotiate
speed 100
duplex full

interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 10.0.10.200 255.255.255.0
no ip route-cache
!
ip default-gateway 10.0.10.10
ip http server
!
[/code:1]

i would highly appriciate any help on this
thanx in adv
Frank
More
16 years 10 months ago #23795 by skepticals
Have you checked to make sure the default gateways of the PCs are correct?
More
16 years 10 months ago #23805 by the_blast
Hi,

Yes i did...
its freaking me :-)
More
16 years 10 months ago #23825 by skepticals
Humm... How are you trying to communicate between the computers? Ping?

It's not something silly like the Windows Firewall?
Time to create page: 0.123 seconds