Skip to main content

intervlan not working

More
16 years 4 months ago #26114 by omer84
intervlan not working was created by omer84
Hi guyz,, i need ur help on the following output,, am stuck with intervlan,, host in vlan 6 are pinging each other, but cant ping vlan3 host, i m using f0/1 as trunk mode, i m using static route.
i m not sure why i cant make it whats the error.





switch summary

Vlan1 10.5.0.0 255.0.0.0
Vlan3 10.2.0.0 255.0.0.0
Van6 10.6.0.0 255.0.0.0

vlan 3- ports f0/3
vlan 6- ports f0/6 f-/7


switch#sh run
!
ip subnet-zero
!
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/6
switchport access vlan 6
!
interface FastEthernet0/7
switchport access vlan 6
!
interface Vlan1
ip address 10.5.0.0 255.0.0.0
no ip route-cache
!
interface Vlan3
ip address 10.2.0.0 255.0.0.0
no ip route-cache
!
interface Vlan6
ip address 10.6.0.0 255.0.0.0
no ip route-cache
!
ip http server
!
End


switch#sh vlan

VLAN Name Status Ports
----


1 default active Fa0/2, Fa0/4, Fa0/5, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
3 HD active Fa0/3
6 NOC active Fa0/6, Fa0/7



*****ROUTER SUMMARY*****

subinterface
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.3.0.1 255.0.0.0
!
interface FastEthernet0/1.6
encapsulation dot1Q 6
ip address 10.6.0.1 255.0.0.0


Router#sh run

!
hostname Router
!
ip subnet-zero
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
!
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.3.0.1 255.0.0.0
!
interface FastEthernet0/1.6
encapsulation dot1Q 6
ip address 10.6.0.1 255.0.0.0
!
ip classless
no ip http server
ip route 0.0.0.0 0.0.0.0 10.5.0.0
More
16 years 4 months ago #26116 by Elohim
Replied by Elohim on topic Re: intervlan not working
I would start with getting rid of these statements:

!
interface Vlan1
ip address 10.5.0.0 255.0.0.0
no ip route-cache
!
interface Vlan3
ip address 10.2.0.0 255.0.0.0
no ip route-cache
!
interface Vlan6
ip address 10.6.0.0 255.0.0.0
no ip route-cache
!

Hi guyz,, i need ur help on the following output,, am stuck with intervlan,, host in vlan 6 are pinging each other, but cant ping vlan3 host, i m using f0/1 as trunk mode, i m using static route.
i m not sure why i cant make it whats the error.





switch summary

Vlan1 10.5.0.0 255.0.0.0
Vlan3 10.2.0.0 255.0.0.0
Van6 10.6.0.0 255.0.0.0

vlan 3- ports f0/3
vlan 6- ports f0/6 f-/7


switch#sh run
!
ip subnet-zero
!
spanning-tree extend system-id
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/6
switchport access vlan 6
!
interface FastEthernet0/7
switchport access vlan 6
!
interface Vlan1
ip address 10.5.0.0 255.0.0.0
no ip route-cache
!
interface Vlan3
ip address 10.2.0.0 255.0.0.0
no ip route-cache
!
interface Vlan6
ip address 10.6.0.0 255.0.0.0
no ip route-cache
!
ip http server
!
End


switch#sh vlan

VLAN Name Status Ports
----




1 default active Fa0/2, Fa0/4, Fa0/5, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
3 HD active Fa0/3
6 NOC active Fa0/6, Fa0/7



*****ROUTER SUMMARY*****

subinterface
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.3.0.1 255.0.0.0
!
interface FastEthernet0/1.6
encapsulation dot1Q 6
ip address 10.6.0.1 255.0.0.0


Router#sh run

!
hostname Router
!
ip subnet-zero
!
interface FastEthernet0/1
no ip address
no ip directed-broadcast
!
interface FastEthernet0/1.3
encapsulation dot1Q 3
ip address 10.3.0.1 255.0.0.0
!
interface FastEthernet0/1.6
encapsulation dot1Q 6
ip address 10.6.0.1 255.0.0.0
!
ip classless
no ip http server
ip route 0.0.0.0 0.0.0.0 10.5.0.0

More
16 years 4 months ago #26128 by omer84
Replied by omer84 on topic Re: intervlan not working
i did not get the point ,, y would u get ride of VLAns which u mentioned,
and wat shld i do after removing those vlans,, as per my knowledge ,, vlans shld had an ip
More
15 years 9 months ago #28441 by donjuan
Replied by donjuan on topic Re: intervlan not working
try to enable 'ip routing' on your switch, hope it help.. :P :P
More
15 years 7 months ago #29319 by harishankargiri
hi you have to configure router interface f0/1 as a trunk
More
15 years 7 months ago #29323 by Smurf
Replied by Smurf on topic Re: intervlan not working
Hi,

If your switch is infact a Layer 3 switch that has the correct IOS image to support Layer3 functionality, then the advice by "donjuan" should get this working as it will enable intervlan routing.

If, you switch is only a normal layer 2 switch then you will need to setup a router (or some sort of layer 3 device that will route VLAN traffic) and enable the switch port that the Router is plugged into as a VLAN Trunk. Then enable this on the Router and setup the sub interfaces with each VLAN ID and the Gateway address.

Cheers

Wayne Murphy
Firewall.cx Team Member
www.firewall.cx

Now working for a Security Company called Sec-1 Ltd in the UK, for any
Penetration Testing work visit www.sec-1.com or PM me for details.
Time to create page: 0.156 seconds