- Posts: 3
- Thank you received: 0
1 Cisco 2611 - 2 DSL connections - Possible ?
- Bananaskin
- Topic Author
- Offline
- New Member
Less
More
17 years 6 months ago #21770
by Bananaskin
1 Cisco 2611 - 2 DSL connections - Possible ? was created by Bananaskin
Hi there,
My present setup atm is 2 x Cisco 1760's connected via WIC1-ENET to 2 ethernet DSL Modems, both routers connected to a 2924XL Switch etc etc.
I have in my possession a 2611 complete with a NM-4E module and was wondering would it be possible to have both DSL modems connected to the 2611 not for load balance or failover just so that there are 2 DSL connections on 1 router, only 1 requires inbound connections to services that I am allowing on a server. One of my DSL connections is Static IP'd, other is Dynamic.
I appreciate that there maybe issues, ie ip nat out and inside statements.
The purpose of the exercise is to have 1 Router with 2 DSL connections serving 2 Networks eg 192.168.1.x and 2.x
Help, Assistance or other advice appreciated.
VMT
My present setup atm is 2 x Cisco 1760's connected via WIC1-ENET to 2 ethernet DSL Modems, both routers connected to a 2924XL Switch etc etc.
I have in my possession a 2611 complete with a NM-4E module and was wondering would it be possible to have both DSL modems connected to the 2611 not for load balance or failover just so that there are 2 DSL connections on 1 router, only 1 requires inbound connections to services that I am allowing on a server. One of my DSL connections is Static IP'd, other is Dynamic.
I appreciate that there maybe issues, ie ip nat out and inside statements.
The purpose of the exercise is to have 1 Router with 2 DSL connections serving 2 Networks eg 192.168.1.x and 2.x
Help, Assistance or other advice appreciated.
VMT
17 years 6 months ago #21783
by semper
James
www.securitygeek.net
Replied by semper on topic Re: 1 Cisco 2611 - 2 DSL connections - Possible ?
You could do something like:
interface ethernet0
description ## DSL Connection 1 DHCP
ip address dhcp
no shutdown
ip nat outside
interface ethernet1
description ## DSL Connection 2 Static
ip address <enter_in_IP_Address_from_ISP> <subnetmask assigned by ISP>
no shutdown
ip nat outside
interface ethernet2
description ## LAN Connection 1
ip address 192.168.1.254 255.255.255.0
no shutdown
ip nat inside
interface ethernet3
description ## LAN Connection 2
ip address 192.168.2.254 255.255.255.0
no shutdown
ip nat inside
access-list 1 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface ethernet0 overload
ip nat inside static tcp 192.168.2.1 80 <IP_Address_assigned_by_ISP> tcp 80
ip route 0.0.0.0 0.0.0.0 ethernet0
ip route 0.0.0.0 0.0.0.0 <GW_defined_by_ISP>
that should work. I've never tested something like that out though.
I could possibly setup a lab to test the configuration.
interface ethernet0
description ## DSL Connection 1 DHCP
ip address dhcp
no shutdown
ip nat outside
interface ethernet1
description ## DSL Connection 2 Static
ip address <enter_in_IP_Address_from_ISP> <subnetmask assigned by ISP>
no shutdown
ip nat outside
interface ethernet2
description ## LAN Connection 1
ip address 192.168.1.254 255.255.255.0
no shutdown
ip nat inside
interface ethernet3
description ## LAN Connection 2
ip address 192.168.2.254 255.255.255.0
no shutdown
ip nat inside
access-list 1 192.168.1.0 0.0.0.255
ip nat inside source list 1 interface ethernet0 overload
ip nat inside static tcp 192.168.2.1 80 <IP_Address_assigned_by_ISP> tcp 80
ip route 0.0.0.0 0.0.0.0 ethernet0
ip route 0.0.0.0 0.0.0.0 <GW_defined_by_ISP>
that should work. I've never tested something like that out though.
I could possibly setup a lab to test the configuration.
James
www.securitygeek.net
- Bananaskin
- Topic Author
- Offline
- New Member
Less
More
- Posts: 3
- Thank you received: 0
17 years 6 months ago #21784
by Bananaskin
Replied by Bananaskin on topic Re: 1 Cisco 2611 - 2 DSL connections - Possible ?
Hey thats great, my one concern was the ip nat inside/outside statements and the possibility of the mixup.
You have a cfg option of "ip nat inside source list 1 interface ethernet0 overload" would that not mean that only 1 i/f would be available for outgoing packets ? would there be a requirement to have the same again with the other ethernet i/f ?
Don't get me wrong, I a appreicate the help... was just a question
You have a cfg option of "ip nat inside source list 1 interface ethernet0 overload" would that not mean that only 1 i/f would be available for outgoing packets ? would there be a requirement to have the same again with the other ethernet i/f ?
Don't get me wrong, I a appreicate the help... was just a question
You could do something like:
Rest Deleted for Brevity
I could possibly setup a lab to test the configuration.
Time to create page: 0.134 seconds