- Posts: 3
- Thank you received: 0
Rip not working
- shaqywacky
- Topic Author
- Offline
- New Member
Less
More
14 years 10 months ago #33154
by shaqywacky
Rip not working was created by shaqywacky
Hello everyone, I working on earning a CCENT and I just got to routing, but Its not working for some reason.
I'm using packet tracer and am useing these commands:
[code:1]
Router(config)#router rip
Router(config-router)#network 192.168.0.0
[/code:1]
but when I check the routing table I only get directly connected hosts.
Is there something I'm not doing right or at all?
Thanks for any help
BTW, I could upload the packet tracer file if you want to see it
I'm using packet tracer and am useing these commands:
[code:1]
Router(config)#router rip
Router(config-router)#network 192.168.0.0
[/code:1]
but when I check the routing table I only get directly connected hosts.
Is there something I'm not doing right or at all?
Thanks for any help
BTW, I could upload the packet tracer file if you want to see it
- broadcaststorm
- Offline
- Junior Member
Less
More
- Posts: 79
- Thank you received: 0
14 years 10 months ago #33155
by broadcaststorm
Replied by broadcaststorm on topic Re: Rip not working
You need to have another router attached to your router and it needs to be advertising out a different network for you to be seeing learned routes with the appropriate admin distance listed.
You also need to have the interfaces up up, which means applying IP addresses to the interfaces. If they're serial interfaces, remember to configure clock rates and (usually) swap the encapsulation away from the default HDLC to PPP.
IME, the best way to get this type of thing to work in a lab needs 3 routers, as that allows you to have some interesting output.
You also need to have the interfaces up up, which means applying IP addresses to the interfaces. If they're serial interfaces, remember to configure clock rates and (usually) swap the encapsulation away from the default HDLC to PPP.
IME, the best way to get this type of thing to work in a lab needs 3 routers, as that allows you to have some interesting output.
- broadcaststorm
- Offline
- Junior Member
Less
More
- Posts: 79
- Thank you received: 0
14 years 10 months ago #33156
by broadcaststorm
Replied by broadcaststorm on topic Re: Rip not working
One quick bit of config (using 3 routers on Packet Tracer) later:
Top router:
Int ser 0/0
ip add 100.140.10.1 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 100.140.10.0
Middle Router:
int ser 0/0
ip add 100.140.10.2 255.255.255.0
encap ppp
clo rat 128000
no shut
Int ser 0/1
ip add 200.140.10.1 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 100.140.10.0
network 200.140.10.0
Bottom:
int ser 0/1
ip add 200.140.10.2 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 200.140.10.0
Given the above config with three routers connected by serial cables, executing a sho ip route command on the Bottom router produces these results:
BOTTOM#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 100.0.0.0/8 [120/1] via 200.140.10.1, 00:00:17, Serial0/1
C 200.140.10.0/24 is directly connected, Serial0/1
All routers running RiPv1, although with either version of RiP, the output at this stage would be the same except that with RiPv2, subnetted networks would be recognised.
Top router:
Int ser 0/0
ip add 100.140.10.1 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 100.140.10.0
Middle Router:
int ser 0/0
ip add 100.140.10.2 255.255.255.0
encap ppp
clo rat 128000
no shut
Int ser 0/1
ip add 200.140.10.1 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 100.140.10.0
network 200.140.10.0
Bottom:
int ser 0/1
ip add 200.140.10.2 255.255.255.0
encap ppp
clo rat 128000
no shut
router rip
network 200.140.10.0
Given the above config with three routers connected by serial cables, executing a sho ip route command on the Bottom router produces these results:
BOTTOM#sho ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
R 100.0.0.0/8 [120/1] via 200.140.10.1, 00:00:17, Serial0/1
C 200.140.10.0/24 is directly connected, Serial0/1
All routers running RiPv1, although with either version of RiP, the output at this stage would be the same except that with RiPv2, subnetted networks would be recognised.
- shaqywacky
- Topic Author
- Offline
- New Member
Less
More
- Posts: 3
- Thank you received: 0
14 years 10 months ago #33157
by shaqywacky
Replied by shaqywacky on topic Re: Rip not working
Thanks, I got mine to work from doing what you said but I noticed something weird. After I do all the "network <network addy>" commands, when I look at the running config, it changes to "network 192.168.1.0".
I changed it to version 2 but It still does the same thing.
Is this something to worry about?
I changed it to version 2 but It still does the same thing.
Is this something to worry about?
- broadcaststorm
- Offline
- Junior Member
Less
More
- Posts: 79
- Thank you received: 0
14 years 10 months ago #33162
by broadcaststorm
Replied by broadcaststorm on topic Re: Rip not working
At the network command, you should be adding the network address, not a host address. And in either version of RIP, there is no need to add a wildcard mask to the network address input, so the complete command looks like this:
Router (config-router)#network 192.168.1.0
Router (config-router)#network 192.168.1.0
- shaqywacky
- Topic Author
- Offline
- New Member
Less
More
- Posts: 3
- Thank you received: 0
14 years 10 months ago #33169
by shaqywacky
Replied by shaqywacky on topic Re: Rip not working
Oh, I see, I was putting in the network ID of each interface that was connected.
Time to create page: 0.137 seconds